Showing posts with label Juniper. Show all posts
Showing posts with label Juniper. Show all posts

Juniper DHCP Server Configuration

September 01, 2015
We already configure our QEMU in GNS3 and run our vSRX Router. Now its time to configure DHCP server in our vSRX router. Lets began.
Logical Diagram for this tutorial



To configure DHCP server

Assign Lowest and highest IP range
root# set system services dhcp pool 192.168.1.0/24 address-range low 192.168.1.50 high 192.168.1.200

Assign DNS server (in my case I had used Router interface IP)
root# set system services dhcp pool 192.168.1.0/24 name-server 192.168.1.1

Assign IP address of the router
root# set system services dhcp pool 192.168.1.0/24 router 192.168.1.1

Assign the lease time
root# set system services dhcp pool 192.168.1.0/24 default-lease-time 3600



Assign DHCP as an allowed inbound service for the interface which we are going to enable DHCP.

root# set security zones security-zone untrust interfaces ge-0/0/1 host-inbound-traffic system-services dhcp

Assign IP address to the client faced interface.
root# set interfaces ge-0/0/1 unit 0 family inet address 192.168.1.1/24



Check our client get the IP Address from the server.


How to statically assign IP with fixed MAC address

root#set system service dhcp static-binding 00:50:79:66:68:00 fixed-address 192.168.1.100

PC1>show ip

Request DHCP IP

PC1>dhcp -d




Enjoy

vSRX GNS3 QEMU

September 01, 2015
In this tutorial I'm going to run vSRX JunOS in QEMU and configure it as DHCP Server. Lets began with installing vSRX into QEMU.

I have try vSRX to run into Vbox but never succeeded. So I better to choose QEMU otherwise waste of time.

In my case I had used junos-vsrx-12.1X46-D10.2-domestic to mount into QEMU. Search for it.
Now we have to convert our .vdi file into .image, for that use following command

cd d:\junos\
c:\Program Files\GNS3\qemu\>qemu-img.exe convert -O qcow2 d:\junos\junos-vsrx-12.1X46-D10.2-domestic-disk1.vdi d:\junos\junos-vsrx-12.1X46-D10.2-domestic.img

We just made our image ready to run into QEMU. Go the GNS3

Note: Strongly recommended to use QEMU in linux and enable KVM otherwise it eats up all your CPU and RAM.

-nographic -smp 2 -enable-kvm

>edit>preference>choose "QEMU VMs"
Click on "New" Choose "Default " Gave Name "vSRX" (in my case).






I'll use following topology to configure DHCP server for the tutorial. 



Now we ready to move on the next step. Configuration DHCP








Juniper Message from syslogd

September 01, 2015
While doing some lab test, this weird syslogd message appear every seconds on the console terminal, so it was very difficult to complete the lab.


This messages are due the following syslog configuration . 


So for now we are going to de-activate it to generating the message

#deactivate system syslog user * 
#commit

show command juniper switch

April 21, 2015
Here are some useful command in day to day life while troubleshooting the juniper switch. 

1. show mac add of specific vlan
  root@jpudasaini#show ethernet-switching table vlan 608

2. compare configure before commit
  root@jpudasaini#show | compare

3. check mac add
  root@jpudasaini#show ethernet-switching table brief

4. show perticular Mac in Juniper
  root@jpudasaini#show ethernet-switching table | match d4ca.6dea.d420

5. show port description/status
  root@jpudasaini#show interfaces descriptions statistics

6. Show configuration in configuration mode
  root@jpudasaini#show configuration | display set

7. show correctness of the command before commit
  root@jpudasaini#commit check

8. Show Link Layer detection Protocol 
  root@jpudasaini#show protocols lldp 

9. Show vlan in configuration mode
root@jpudasaini#show vlans | display set

Juniper switch Basic Configuration Commands

December 31, 2014
Hello fellow blog reader, after long gap I'm going to write this thread regarding the basic Juniper command and configuration. I try to include as much as troubleshooting/configuration command during day to day work.
I would like to thank to Srijan pointing the error on LACP command.

1. Set username for login
root@jpudasaini#set system root-authentication encrypted-password
New password:
Retype new password:

root@jpudasaini#set system login user jay full-name jaypudasaini uid 400 class super-user authentication encrypted-password


2. Hostname configuration.
root@switch#set system host-name jpudasaini
root@jpudasaini#

3. Set Tacplus authentication for juniper switch.
root@jpudasaini# set system authentication-order tacplus
root@jpudasaini# set system authentication-order password
root@jpudasaini# set system root-authentication encrypted-password "you password here"
root@jpudasaini# set system tacplus-server 10.10.10.10(your tacplus server IP) secret "your server password here"
root@jpudasaini#set system tacplus-options service-name test

4. Configuration VLAN(Group)
root@jpudasaini#set vlans Cust-Fiber vlan-id 500-550
root@jpudasaini#set vlans Cust-Wireless vlan-id 551-575
    single vlan
root@jpudasaini#set vlans Cust-A vland-id 25

5. Trunk Port Configuration
root@jpudasaini#set interfaces ge-0/0/9 description connect-to-sw2
root@jpudasaini#set interfaces ge-0/0/9 unit 0 family ethernet-switching port-mode trunk
root@jpudasaini#set interfaces ge-0/0/9 unit 0 family ethernet-switching vlan members Cust-Fiber

6. Access Port Configuration
root@jpudasaini#set interfaces ge-0/0/0 description Link-to-sw3
root@jpudasaini#set interfaces ge-0/0/0 unit 0 family ethernet-switching port-mode access
root@jpudasaini#set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members 25

7. Port Channel Configuration
root@jpudasaini#set chassis aggregated-devices ethernet device-count 10
root@jpudasaini#set interfaces ae0 description TR-2-Jpudasaini-Sw2
root@jpudasaini#set interfaces ae0 aggregated-ether-options lacp active
root@jpudasaini#set interfaces ae0 unit 0 family ethernet-switching port-mode trunk
root@jpudasaini#set interfaces ae0 unit 0 family ethernet-switching vlan members Cust-Fiber
root@jpudasaini#set interfaces ae0 unit 0 family ethernet-switching vlan members Cust-Wireless

8. Port Channel Assign to the Physical Port
root@jpudasaini#set interfaces ge-0/0/16 description test-sw1
root@jpudasaini#set interfaces ge-0/0/16 ether-options 802.3ad ae0
root@jpudasaini#set interfaces ge-0/0/17 description test-sw1
root@jpudasaini#set interfaces ge-0/0/17 ether-options 802.3ad ae0

9. Configuration management IP for switch.
root@jpudasaini#set interfaces vlan unit 20 family inet address 10.10.10.11/24

10. Configuration snmp.
root@jpudasaini#set snmp name Test-SNMP
root@jpudasaini#set snmp description test-sw2
root@jpudasaini#set snmp location "Jpudasaini-NOC"
root@jpudasaini#set snmp contact "system@jpudasaini.com.np"
root@jpudasaini#set snmp client-list list0 10.10.10.0/24
root@jpudasaini#set snmp community ax3R5vgW authorization read-only
root@jpudasaini#set snmp community ax3R5vgW client-list-name jpudasaini

11. Enable LLDP
root@jpudasaini# set protocols lldp interface all
root@jpudasaini#set protocols lldp-med interface all

12. Configure port as L3
root@jpudasaini#set interface ge-0/0/23 unit 0 family ethernet-switching port-mode trunk
root@jpudasaini#set interface ge-0/0/23 unit 0 family ethernet-switching vlan member 25
root@jpudasaini#set vlan Mgmt vlan-id 25
root@jpudasaini#set vlan Mgmt l3-interface vlan.25
root@jpudasaini#set interface vlan.250 family inet address xxx.xxx.xxx.xxx

13.Rate Limit
 Configure the policer

root@jpudasaini# set firewall policer Policer_2M if-exceeding bandwidth-limit 1M
root@jpudasaini# set firewall policer Policer_2M if-exceeding burst-size-limit 2k
root@jpudasaini# set firewall policer Policer_2M then discard

Configure the firewall filter

root@jpudasaini# set firewall family ethernet-switching filter Limit term 1 then accept
root@jpudasaini# set firewall family ethernet-switching filter Limit term 1 then policer Poicer_2M

Apply filter on interface (can be any interface as required)

root@jpudasaini# set interface ge-0/0/24.0 family ethernet-switching filter input Limit

Note: Remember that EX series switches apply rate limit only on ingress. 

This Device has Booted from the Backup JunOS Image EX and SRX

August 02, 2014
Recently I encounter weird issue with JunOS. While Cold Booting the Juniper ex4200 switch its shows following message.

I do nothing just first boot the device thus face unknown reason message. Then I dig the google however some command doesn't work except below one. This JunOS version was 12.3.

sw1@jpudasaini>show system storage partition

Solution
EX
root>request system reboot slice alternate media internal 

SRX
root>request system reboot media internal 

Now reboot your device and the error message is already gone. To verify the which boot partition do used by your device use the following command.

BTX loader 1.00 BTX loader is 1.02

May 22, 2014
In my previous blog post you know how to make JunOS vdi to install into Virtuabox. Some of you may try to run it fromVBox main window. When ever you try to run JunOS from VBox window you may encounter below error message and nothing happen.
BTX loader 1.00 BTX loader is 1.02
Don't run it form the VirtuaBox main windows. Please go to my previous blog post.

JunOS VirtualBox GNS3

April 05, 2014
 This is the Step 2 in our GNS3 Lab with JunOS, Quagga and Cisco router.

I have tried different tutorial posted in other blogs. I've never found any tutorial  work until now. Every-time I stuck at the middle of the tutorials.  In this blog post, I'll show you how to install JunOS in VBox and later I'll integrate it into GNS3 lab.

I have take Olive12.1R1.9.img, I know you're smart to get it from the Internet. Lets begin the installation of JunOS. Before that, convert the JunOS image into Vbox vdi Image.

For easy installation and to avoid error during this tutorial, enter into the JunOS folder, in my case.

This tutorials assume that you have already install GNS3 and VBox.


Step 1

Prepare JunOS for VBox.
C:\Users\jpudasaini\Desktop\jun>"C:\Program Files\Oracle\VirtualBox\VBoxmanage" convertdd Olive12.1R1.9.img Olive12.1.R1.9.vdi
Its take time to convert the image, wait for few minute depends on your PC configuration.

Now go to the jun folder you can see Olive12.1R1.9.vdi image is created.

Step 2
  • Open VBox and create New Virtual Machine and give any name choose BSD then FreeBSD.
  • On next window choose at least 512MB RAM, click next.
  • Now its important step, while choosing Hard Drive in this step select "Use an existing virtual hard drive file". Then locate previous created vdi file. In my case "c:\user\jpudasaini\Desktop\jun\Olive12.1R1.9.vdi"
  • Its time to open GNS3>Edit>Preferences>VirtualBox>VirtualBox Guest
  1. Identifier name: Juniper
  2. VM List:- JunOS(In this step you may not seen any VBox OS just click "Refresh VM List"
  3. Click "save" and go the GNS3 main window, 

Add VirtualBox Guest in GNS3 working area. Becareful in this step, don't run guest OS from VBox, just run it from GNS3 Working enviroment area, right clicking and start.
  • To login to router console just right click JunOS and choose"console" now you can login to router console with ID "root" no password.


Your JunOS router is ready to used.


Enjoy! :)